В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ertadaysma
Ertadaysma
31.10.2020 09:31 •  Информатика

Запишите правильную последовательность цифр так чтобы получилась программа получается рисунок. Команды даны в таблице под рисунком.
ПаМаГиТе

Показать ответ
Ответ:
catdog12
catdog12
21.10.2022 12:56
Вариант с процедурой Delete

var
  s:string;
  k:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  Delete(s,k,1);
  Writeln('Результат: ',s)
end.

Вариант с функцией Copy

var
  s:string;
  k,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s:=Copy(s,1,k-1)+Copy(s,k+1,n-k);
  Writeln('Результат: ',s)
end.

Вариант с циклами

var
  s,s1:string;
  k,i,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s1:='';
  for i:=1 to k-1 do s1:=s1+s[i];
  for i:=k+1 to n do s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовое решение (одинаково для всех вариантов):
Введите слово: Таракан
Какую по порядку букву удалить? 4
Результат: Таркан

Блок-схемы всех вариантов находятся во вложениях
0,0(0 оценок)
Ответ:
shkuta03
shkuta03
11.07.2020 01:52
26. Наибольший  объем памяти потребуется для хранения ...
a) слова "укроп"
b) числа 22
✔ c) слова "десять" - числа даже если их хранить как строки, потребуют не больше 3 символов. В "укроп"е символов 5, а тут 6 - больше всего.
d) числа 777

27. Один бит - это такое количество информации, когда неопределенность...
a) увеличивается в 2 раза
✔ b) уменьшается в 2 раза - определение бита.
c) уменьшается в 8 раз
d) увеличивается в 8 раз

28. Переведите число 101010101 из двоичной системы счисления в десятичную
a) 361
b) 564
c) 455
✔ d) 341 = 2^8 + 2^6 + 2^4 + 2^2 + 2^0 = 101010101_2

29. Сколько байтов в 4 Кбайтах?
a) 4 х 10^6
✔ b) 4 x 2^10 - 1 Кбайт = 2^10 байт
c) 4 x 10^21
d) 4 x 2^32

30. Каков результат перевода числа 216 из десятичной системы счисления в двоичную?
a) 11001100
✔ b) 11011000 = 2^7 + 2^6 + 2^4 + 2^3 = 216
c) 11100000
d) 11001000

31. Число 32 в десятичной системе эквивалентно числу в двоичной системе...
✔ a) 100000 = 2^5
b) 35
c) 21
d) 1000

32. Сколько цифр в двоичной системе счисления
a) 1
b) 0
✔ c) 2 - это "0" и "1".
d) 3

33. Количество битов в 43 килобайтах равно ... 
a) 43 х 10^3
✔ b) 344 x 2^10 - В 1 Кбайте 2^10 байт, в 1 байте 8 бит
c) 43 x 10^6
d) 344 x 10^3

34. Не является своиством информации..
a) Понятность
b) Полнота
✔ c) Прямолинейность
d) Доступность

35. Сколько секунд потребуется для передачи сообщения  со  скоростью 14 400  бит/с, 
чтобы передать 225 кбайт?
a) 512
b) 125
✔ c) 128 = 225 * 1024 * 8 / 14 400
d) 400

36. Килобайт - это...
a) 1000 символов
b) 8 бит
c) 1000 байт
✔ d) 1024 байт

37. Сколько битов в слове "Байт"?
a) 8
b) 24
✔ c) 32 - четыре символа, каждый по 1 байту = 8 бит
d) 4

38. Наименьший объем памяти требуется для хранения...
✔ a) Целой числовой величины - вопрос не вполне корректный, неизвестно, какой диапазон изменения величин. Если на символ тратить 1 байт, то 10 байт - точно больше, чем отводится на число (2-4 байта обычно). Если считать, что целые числа маленькие, то на их хранение нужно меньше места, чем на вещественное число. Графический примитив хранит внутри себя хотя бы один вещественный параметр, так что он занимает не меньше места, чем вещественное число.
b) вещественной числовой величины
c) строки символов из 10 слов
d) графического примитива

39. Для хранения числа - 52 понадобится...
a) 4 байта
✔ b) 2 байта - число маленькое, в 2 байта влезает (от -16 с чем-то тысяч до +16 с чем-то тысяч)
c) 1 килобайт
d) 52 бита

40. Одним из основных свойств информации является
✔ a) Доступность
b) Результативность
c) Хаотичность
d) Измеримость

41. Какой объем информации содержит слово "школа!"
a) 2 Мбайт
b) 1 Мбайт 
✔ c) 6 байт - 6 символов по 1 байту
d) 60 бит

42. Десятичное число 37 в двоичной системе счисления будет равно ...
✔ a) 100101 = 2^5 + 2^2 + 2^0 = 37
b) 1100101
c) 100111
d) 1000000

43. Какое из приведенных ниже равенств верно?
a) 5 в десятичной системе = 00000111 в двоичной (это 2^2 + 2^1 + 2^0 = 7)
✔ b) 47 в десятичной системе = 101111 в двоичной (это 2^5 + 2^3 + 2^2 + 2^1 + 2^0 = 47)
c) 13 в десятичной системе = 00011111 в двоичной (это 2^4 + 2^3 + 2^2 + 2^1 + 2^0 = 31)
d) 2 в десятичной системе = 00001000 в двоичной (это 2^3 = 8)

44. Не является носителем информации...
a) Книга
b) Глобус
✔ c) Ручка - на всем другом хранится информация, ручка - устройство записи
d) Видеопленка

45. Считая, что каждый символ кодируется одним байтом, оцените информационый объем 
фразы: "Один пуд - около 16,4 килограмма"
a) 32 Кбайта
b) 512 бит
c) 64 бита
✔ d) 32 байта - 32 символа по 1 байту

46. Сколько байт информации содержит сообщение объемом 216 бит
a) 16
b) 28
✔ c) 27 (в 1 байте 8 бит, 216 бит = 216/8 байт)
d) 32

47. Сообщение, информационный объем которого равен 32  битам, соответствует объему 
информации в байтах...
a) 5
b) 2
c) 3
✔ d) 4 (32 бита = 32/8 байт)

48. Сообщение, имеющее информационный объем 800 бит, содержит количество символов...
a) 10
b) 80
✔ c) 100 (1 байт = 8 бит на символ)
d) 8

49. В какой системе счисления хранится информация в компьютере?
a) Троичной
✔ b) Двоичной
c) Десятичной
d) Двенадцатиричной

50. Сколько двоичных цифр можно записать в двух байтах?
a) 2
b) 8
✔ c) 16 (2 байта = 2*8 бит)
d) 32
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота