В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

: Запишите решение задач на языке программирования Паскаль.
1. Определить площадь трапеции по введенным значениям оснований (а и
b) и высоты (h).
2. Вычислите значения: x=a+b при a>b, x=a*b, при а<=b.
3. Вычислите среднее арифметическое для чисел от 1 до n.
4. Вычислите произведение нечетных чисел от 1 до n.
5. Составьте программу для решения квадратного уравнения
a*x2 + b*x +с = 0
Хоть некоторые, ​

Показать ответ
Ответ:
qwertyuiop330
qwertyuiop330
13.07.2021 20:22
#include <stdio.h>#include <locale.h>#include <conio.h>int main(){ int boys = 0, count_boys = 0; int girls = 0, count_girls = 0; int tmp = 1; setlocale(LC_ALL, "rus"); printf("Введите рост ученика\nРост мальчиков задается отрицательными значениями\nРост девочек положительными\n"); printf("Введите 0 если ввели рост всех учеников\n"); // вводим рост учеников while (tmp != 0) { scanf_s("%d", &tmp); if (tmp > 0) { girls += tmp; count_girls++; } else if (tmp < 0) { boys += tmp; count_boys++; } } // вычисляем средний рост учеников if (count_boys > 0 && count_girls > 0) {  boys = -boys / count_boys; girls = girls / count_girls; } else { printf("Рост мальчиков либо девочек не был задан\n"); _getch(); return 0; }
if ((boys - girls) > 10) printf("Средний рост мальчиков больше среднего роста девочек на 10 см\n"); else printf("Средний рост мальчиков не превышает среднего роста девочек на 10 см\n"); _getch(); return 0;}
// попытка №2

Решить на с++ известен рост каждого ученика класса. рост мальчиков условно задан отрицательными числ
0,0(0 оценок)
Ответ:
stardark03
stardark03
08.11.2020 14:04

1. Образовательные:

сформировать представления о назначении и принципах построения локальных компьютерных сетей;

сформировать знания о составе и основах функционирования локальных компьютерных сетей;

2. Развивающие:

развить познавательные и творческие учащихся;

развить образное мышление;

развивать готовность учащихся к информационно-учебной деятельности, применять инструментальные средства и средства информационных технологий в любом предмете для реализации учебных целей и саморазвития.

3. Воспитательные:

воспитывать трудолюбие, ответственность за результаты своего труда:

воспитывать культуру делового общения при совместной работе в группе;

воспитывать доброжелательность среди учащихся, нацеленность на результативность обучения.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота