В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
МсПолинэ
МсПолинэ
28.01.2023 09:32 •  Информатика

Заполнить двумерный массив f размером x*y целыми случайными числами из промежутка [-130; 130] и вывести этот массив на экран. определить количество чисел некратных 5 в заданном массиве. расписать этапы. составить блок-схему. выполнить трассировку всех этапов для массива размером 2*3. написать программу.

Показать ответ
Ответ:

program massive;

const

x=2;

y=3;

var  

 f: array [1..x,1..y] of integer;

 i,j,s:integer;

begin

 randomize;

 s:=0;

 for i:=1 to x do

   begin

     for j:=1 to y do

       begin

         f[i,j]:=random(-130,130);

         write(f[i,j],' ');

       end;

     writeln;

   end;

 for i:=1 to x do

   for j:=1 to y do

     if f[i,j] mod 5 <> 0 then  

       s:=s+1;

 if s=0 then  

   writeln('Все элементы fкратны 5')

 else  

   writeln('Элементов не кратных 5: ',s);

end.

1) Заполняем массив случайными элементами

2) Проверяем каждый элемент на кратность  5

3) И считаем их количество


Заполнить двумерный массив f размером x*y целыми случайными числами из промежутка [-130; 130] и выве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота