В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sirghiina
sirghiina
21.01.2020 03:29 •  Информатика

Заполнить и вывести массив из 7чисел, так чтобы значения элементов массива - совпадали с их индексами (Паскаль)

Показать ответ
Ответ:
кира650
кира650
08.02.2023 15:28

Представлю 3 программы два с массивом и один без массива

1)var a:array [1..10] of integer;

i,n,k5,k2:integer;

begin

 writeln('введите количество экзаменов');

 read(n);

 for i:=1 to n do  begin

   writeln('введите оценку за экзамен');

   readln(a[i]);

 end;

  for i:=1 to n do  begin

    if a[i]=5 then k5:=k5+1;

    if a[i]=2 then k2:=k2+1;

  end;

  writeln('количество пятерок ',k5);

   writeln('количество двоек ',k2);

end.

2)var a:array [1..10] of integer;

i,n,k5,k2:integer;

begin

 writeln('введите количество экзаменов');

 read(n);

 for i:=1 to n do  begin

   writeln('введите оценку за экзамен');

   readln(a[i]);

    if a[i]=5 then k5:=k5+1;

    if a[i]=2 then k2:=k2+1;

  end;

  writeln('количество пятерок ',k5);

   writeln('количество двоек ',k2);

end.

3)var a,i,n,k5,k2:integer;

begin

 writeln('введите количество экзаменов');

 read(n);

if n<=10 then begin

 for i:=1 to n do  begin

     writeln('введите оценку за экзамен');

   readln(a);

    if a=5 then k5:=k5+1;

    if a=2 then k2:=k2+1;

  end;

  writeln('количество пятерок ',k5);

   writeln('количество двоек ',k2);

end;

 end.

0,0(0 оценок)
Ответ:
sobkevichbozhep08t40
sobkevichbozhep08t40
22.01.2020 01:31

1.

program z1;

var k: integer;

begin

write ('Введите число: ');

readln(k);

if k > 0 then k:=k*2

else k:=sqr(k);

write('Сейчас число: ',k)

end.

2.

program z2;

uses GraphABC;

var k: integer;

begin

SetFontSize(15);

write ('Введите число: ');

read(k);

write(k);

if k mod 2 = 0 then

begin

SetBrushColor(clred);

FillRectangle(220,140,420,340)

end

else

begin

SetBrushColor(clblue);

FillCircle(320,240,100)

end

end.

3.

program z3;

var k: integer;

begin

write ('Введите число: ');

readln(k);

write((k>99)and(k<1000))

end.

Объяснение:

Условный оператор:

if условие then действие 1 else действие 2

k > 0 - условие проверки числа на положительность (если число больше 0)

k mod 2 = 0 - условие проверки числа на чётность (если число делится на 2 без остатка)

mod - остаток от целочисленного деления

write((k>99)and(k<1000))  - если число трёхзначное, то ответ True, иначе False


Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота