В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
muliku
muliku
22.02.2021 11:46 •  Информатика

Заполнить массив из элементов случайными числами в интервале [-15..15] и найти в нем максимальный и минимальный элементы и их номера. Язык паскаль Написать программу.

1. Число элементов массива задаете индивидуально.

2.Перед выводом массива вывести на экран, что надо найти в задаче и характеристики массива.

3. Вывод результата согласно примеру.

4. Добавить комментарий к каждой строке программы.

Пример:

Исходный массив:

4 -5 3 10 -4 -6 8 -10 1 0

максимальный a[4]=10

минимальный a[8]=-10

Показать ответ
Ответ:
NICHEGOHOROSHEGO1
NICHEGOHOROSHEGO1
08.08.2022 03:34

Код программы:

#include <iostream>

#include <locale>

using namespace std;

double Mediana(double x, double y, double z) {

double m;

m = 0.5*(2 * y*y + 2 * z*z - x*x);

return m;

}

int main()

{

setlocale(LC_ALL, "Russian");

double a, b, c, ma, mb, mc;

cout << "a = ";

cin >> a;

cout << "b = ";

cin >> b;

cout << "c = ";

cin >> c;

cout<<"Медиана к стороне А = "<< Mediana(a, b, c)<<endl;

cout <<"Медиана к стороне B = "<< Mediana(b, c, a)<<endl;

cout <<"Медиана к стороне C = "<< Mediana(c, a, b)<<endl;

return 0;

}

0,0(0 оценок)
Ответ:
viktoska87
viktoska87
11.04.2020 13:17
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота