Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Ариана16112001
28.03.2023 17:29 •
Информатика
Заполнить массив на 30 целочисленных элементов псевдослучайными значениями от -200 до 200, найти самое большое отрицательное число и самое маленькое положительное (паскаль)
Показать ответ
Ответ:
langueva1405
05.10.2020 12:31
Program prog;
Uses crt;
var a: array [0..29] of integer;
max, min, i: integer;
begin;
clrscr;
randomize;
max:=-201;
min:=201;
for i:=0 to 29 do
begin
a[i]:=random(401)-200;
write(a[i],' ');
if (a[i]>max)and(a[i]<0) then
max:=a[i];
if (a[i]<min)and(a[i]>0) then
min:=a[i];
end;
writeln;
writeln;
writeln('max neg = ', max);
writeln('min pos = ', min);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Daniel200011
26.09.2022 08:22
Задание 3. Выполните задание, используя прием «Кубизм». возьмите обычный бумажный куб, на гранях которого записаны следующие задания: 1. Изучите конфигурацию компьютера. 2. Опишите...
kristinamoroz1
23.03.2023 03:13
Создать проект,в котором построить график функции y=xsinx на промежутке, заданном пользователем.Добавьте в проект перечисленные возможности: Оси координат со стрелками и подписями...
Zen201
04.08.2022 15:27
Сообщение записанное из 65.536 символов алфавита содержит 16 символов Какой объём несёт килобайты...
kholmatova002
25.05.2022 06:41
Составить программу на паскале. агент 007 узнал, что в секретном сейфе трёхзначный код, в котором все три цифры разные.при этом средняя цифра равна разности крайних цифр. составить...
shingekinokoyji
16.09.2022 16:35
1. была получена телеграмма: «встречайте, вагон 8». известно, что в составе поезда 16 вагонов. какое количество информации было получено? 2. при угадывании целого числа в диапазоне...
Толик566
16.09.2022 16:35
Исполнителя удвоитель две команды,у исполнителя удвоитель две команды, которым присвоены номера: 1. умножь на 2.2. прибавь 3первая из них увеличивает число на экране 2 раза, вторая...
bolshikov
16.09.2022 16:35
Информационному сообщению объемом 12 288 бит соответствует а)1536 кбайт б)1,5 мбайт в)1,536 кбайт г)12 кбайт д)1,5 кбайт...
AliceMagic
16.09.2022 16:35
Решить логическую табличным подозреваемые в ограблении банка дали следующие показания: петров: это сделал не я иванов: это сделал сидоров сидоров: это сделал не я алексеев: это...
ДашаКаськова
01.12.2021 22:14
Автомат получает на вход пятизначное десятичное число по полученному числу строится новое десятичное число по следующим правилам вычисляются два числа сумма первых трех цифр сумма...
Pahamoseuv
21.05.2023 22:24
Организуйте в консольном приложении ввод массива полярных координат n точек на плоскости. вычислите массив декартовых координат этих точек и организуйте вывод этого массива. обеспечьте...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Uses crt;
var a: array [0..29] of integer;
max, min, i: integer;
begin;
clrscr;
randomize;
max:=-201;
min:=201;
for i:=0 to 29 do
begin
a[i]:=random(401)-200;
write(a[i],' ');
if (a[i]>max)and(a[i]<0) then
max:=a[i];
if (a[i]<min)and(a[i]>0) then
min:=a[i];
end;
writeln;
writeln;
writeln('max neg = ', max);
writeln('min pos = ', min);
readln;
end.