В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alyonasmirnova5
alyonasmirnova5
18.08.2020 06:15 •  Информатика

Заполнить массив р15 случайными числами и составить программу, которая удвоит элементы меньше !

Показать ответ
Ответ:
юличеноккалина
юличеноккалина
16.05.2021 20:33

Pascal:

var p:array[1..15] of integer;

i:integer;

begin

for i:=1 to 15 do

begin

p[i] := random(31);

if p[i] < 7 then

p[i] := p[i] * 2;

write(p[i], ' ');

end;

end.

Java:

package com.znanija

import java.util.Random;

public class Main {

public static void main(String[] args) {

Random rand = new Random();

int[] p = new int[15];

for (int i=0;i<15;i++) {

p[i] = rand.nextInt(31);

if (p[i] < 7)

p[i] *= 2;

System.out.print(p[i] + " ");

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота