В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
albina8427
albina8427
22.05.2021 09:54 •  Информатика

Заполните массив с клавиатуры целыми числами и найдите индексы тех элементов, модуль которых меньше заданного числа А (А вводить с клавиатуры).

Входные данные:

в первой строке целое число n (0 < n ≤ 100) — кол-во элементов в массиве и число целое А (по модулю не превосходит 32000). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) — значения элементов массива.

Выходные данные:

индексы тех элементов, модуль которых меньше заданного числа А разделенные пробелом. Если элементов с указанными свойствами не оказалось, то выведите число «0».

Показать ответ
Ответ:
alexandra2981278247
alexandra2981278247
11.12.2020 01:30

dictionary = {}

while True:

   command = input('Введите команду: ')

   if command != 'exit' and command != 'list' and command != 'add' and command !=  'delete' and command != 'rate' and command != 'find':

       print('Error')

       continue

   if command == 'exit':

       break

   if command == 'list':

       for key in dictionary.keys():

           average = 0

           if len(dictionary[key]) == 0:

               print(f'Фильм {key} не оценивался')

           else:

               for key1 in dictionary[key].keys():

                   average += dictionary[key][key1]

               print(f'{key} средняя оценка: {average / len(dictionary[key])}')

       continue

   film = input('Введите название фильма: ')

   if command == 'add':

       if film in dictionary:

           print('Error')

       else:

           dictionary[film] = {}

   elif command == 'delete':

       if film in dictionary:

           del dictionary[film]

       else:

           print('Error')

   elif command == 'rate':

       name = input('Имя пользователя: ')

       rate = float(input('Оценка: '))

       if 0 < rate <= 10:

           dictionary[film][name] = rate

       else:

           print('Error')

   elif command == 'find':

       if len(dictionary[film]) == 0:

           print('Фильм не оценивался')

           continue

       for name, rate in dictionary[film].items():

           print(f'{name} поставил оценку: {rate}')

       average = 0

       for key in dictionary[film].keys():

           average += dictionary[film][key]

       print(f'Средняя оценка: {average / len(dictionary[film])}')

0,0(0 оценок)
Ответ:
Kroo66944
Kroo66944
11.12.2020 01:30

def rate_f(movies):

   if len(dictionary[movies]) == 0:

       return True

def film_in_dictionary(movies):

   if movies in dictionary:

       return True

   else:

       return False

def average(movies):

   mean = 0

   for key2 in dictionary[movies].keys():

       mean += dictionary[movies][key2]

   print(f'{movies} средняя оценка: {mean / len(dictionary[movies])}')

dictionary = {}

while True:

   command = input('Введите команду: ')

   if command != 'exit' and command != 'list' and command != 'add' and command != \

           'delete' and command != 'rate' and command != 'find':

       print('Error')

       continue

   if command == 'exit':

       break

   if command == 'list':

       for key in dictionary.keys():

           if rate_f(key):

               print(f'{key} не оценивался')

           else:

               average(key)

       continue

   film = input('Введите название фильма: ')

   if command == 'add':

       if film_in_dictionary(film):

           print('Error')

       else:

           dictionary[film] = {}

   elif command == 'delete':

       if film in dictionary:

           del dictionary[film]

       else:

           print('Error')

   elif command == 'rate':

       name = input('Имя пользователя: ')

       rate = float(input('Оценка: '))

       if 0 < rate <= 10:

           dictionary[film][name] = rate

       else:

           print('Error')

   elif command == 'find':

       if rate_f(film):

           continue

       for name, rate in dictionary[film].items():

           print(f'{name} поставил оценку: {rate}')

       average(film)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота