В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
leski
leski
18.07.2022 23:37 •  Информатика

Заполните массив, состоящий из 20 элементов, случайными целыми от 15 до 100. найдите минимальный элемент из элементов с чётными значениями.

Показать ответ
Ответ:
Dedret
Dedret
11.08.2020 22:43

Объяснение:

program EvenMinimum;

var

a : array [1..20] of integer;

i,min: integer;

begin

   for i:= 1 to 20 do a[i]:=random(85)+15;

   writeln('Default array:');

   for i:=1 to 20 do write(a[i],' ');

   writeln();

   for i:=1 to 20 do if a[i] mod 2 = 0 then min:=a[i];

   for i:=1 to 20 do if (a[i] < min) and (a[i] mod 2 = 0) then min:=a[i];

   writeln('Even minimum in this array is :', min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота