Заранее большое напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных шести и оканчивающихся на шесть программа получает на вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом ноль (ноль- признак окончания ввода не входит в последовательность)количество чисел не превышает 100 .введённое число не превышает 300 программа должна ввести одно число: сумму всех чисел кратных шести и оканчивающихся на шесть входные данные 36 ; 12: 16; 66 ; 11 ; 0 выходные данные 102
1. Алексеев
2. Батракова
3. Воронин
4. Песков
и т.д.
2. Маркированный - например список команд в соревновании в лагере
* шахматисты
* баскетболисты
* волейболисты
* шашисты
* теннисисты
и т.д.
3. Многоуровневый. Например список участников команд по классам
1. 8а класс:
* Смирнова
* Петров
* Исаев
* Кононова
* Антошкин
2. 8б класс:
* Тюлькин
* Свистунова
* Иванов
* Смирнова
* Ручкин
3. 8в класс:
* Петровский
* Золотова
* Крючков
* Сидоров
* Андреева
// Внимание! Если программа не работает, обновите версию!
begin
var p:=Range(1,137);
Writeln('Сумма чисел от 1 до 137 равна ',p.Sum);
Writeln('Их произведение равно ',p.Aggregate(BigInteger(1),(x,y)->x*y))
end.
Результат
Сумма чисел от 1 до 137 равна 9453
Их произведение равно 5012888748274991661034926292112253883237205694398754483388962668892510972746226260034675717797072343372830591567227826571884373881355612819314826377917827129740056802397016509378163883274055583382110208000000000000000000000000000000000