Здравствуйте , кто разбирается в информатике ! 1. Заполните массив из 20 случайных вещественных чисел, вывести его на экран и найти произведение всех элементов массива, имеющих четные номера.
2. Массив из 15 элементов заполните случайными целыми числами из диапазона от 10 до 50 и выведите его на экран.
Выведите на экран все элементы массива, значения которых кратны 4.
3. Заполните массив из 100 случайных целых чисел из диапазона от -10
до +20, вывести его на экран.
А) Определите количество и сумму положительных элементов.
Б) Выведите на экран номера всех отрицательных элементов.
(Нужно сделать в Паскаль).
var x: array[1..nx, 1..nx] of integer;z:array[1..nx*2] of integer;
i, j, k,n,r,t: integer;
begin
Writeln('Введите размер матрицы n');Read(n);
for i := 1 to n do begin
for j := 1 to n do begin
Read(k);x[i, j] := k; end;end;
Writeln('Исходный массив');
for i := 1 to n do begin
for j := 1 to n do begin
Write(x[i, j]:4);
if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j];end;
end;
Writeln; end;
Writeln;Writeln('Одномерный массив');
for j := 1 to t do
Write(z[j]:4);
end.
begin
var n:=ReadInteger('Количество элементов в массиве: ');
var a:=ArrRandom(n,-50,50);
a.Println(',');
Writeln('Четные элементы: ');
var i:=1;
while i<n do begin Write(a[i],' '); Inc(i,2) end;
Writeln;
Writeln('Нечетные элементы: ');
i:=0;
while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
Writeln
end.
Тестовое решение:
Количество элементов в массиве: 10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9