В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
qwerty854
qwerty854
01.04.2021 03:31 •  Информатика

Здравствуйте нужна Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное число, кратное 6 (в тетради письменно)

Показать ответ
Ответ:
amikayilova
amikayilova
25.01.2021 19:14

Объяснение:

program prog;

var  

x,i,n,tmp:integer;

arr:array [1..1000] of integer;

begin

Writeln('Enter n: ');

readln(n);

x:=30000;

Writeln('Enter numbers: ');

for i:=1 to n do readln(arr[i]);

for i:=1 to n do

begin

tmp:=arr[i] mod 6;

if (tmp=0) and (arr[i]<x) then x:=arr[i];

end;

writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота