В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Valercik1
Valercik1
30.01.2021 17:28 •  Информатика

1-2. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчëт суммы и среднего арифметического всех введённых чисел. Сначала запишите эту программу с оператором repeat, а затем с оператором while:

while <условие>do

begin

<серия команд

end:

while <yсловие>do

begin

серия команд>

end;

3. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и вычисление суммы всех чётных чисел из ведённых. Запишите эту программу с оператором repeat или с оператором

while (условие: n mod 2=0).


1-2. Напишите программу, в которой осуществляется ввод любых целых чисел (ввод осуществляется до тех

Показать ответ
Ответ:
ekaterinaring2017
ekaterinaring2017
08.02.2022 04:20

Программа:

Pascal:

№1)

var sum, j, k: integer;

begin

 readln(j);

 while j <> 0 do begin

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 end;

 writeln(sum/k);

end.

№2)

var sum, j, k: integer;

begin

 readln(j);

 repeat

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 until j = 0;

 writeln(sum/k);

end.

№3)

3.1) var sum, j: integer;

begin

 readln(j);

 repeat

   if j mod 2 = 0 then sum += j;

   readln(j);

 until j = 0;

 writeln(sum);

end.

3.2) var sum, j: integer;

begin

 readln(j);

 while j <> 0 do begin

   if j mod 2 = 0 then sum += j;

   readln(j);

 end;

 writeln(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота