В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nik255377866689
nik255377866689
30.09.2022 04:04 •  Информатика

1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении

Показать ответ
Ответ:
маша9393
маша9393
24.05.2020 00:29

for i := 1 to length(s) do

begin

    res := res + s[i];

    if i mod 2 = 0 then

       res := res + s[i];

end;

writeln(res);

 

 

i := Pos(" ",s);{ищем первый пробел}

Delete(s;i;1);{удаляем первый пробел}

i := Pos(" ",s);{ищем второй пробел, котрый теперь первый}

writeln(s[i-1]);{выдаем знак который находится перед пробелом}

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота