В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
operovist
operovist
28.06.2022 14:57 •  Информатика

1)Написать программу, которая вводит число х. Если оно положительно, то вводится еще число y, затем находится и выводится сумма этих чисел. Если х не является положительным, надо найти и вывести его квадрат
2)Даны 2 числа А и В. Если они оба четные, увеличить их значения на 10 и вывести новые значения переменных; в противном случае найти их утроенное произведение и вывести его.
3)Даны два положительных числа. Если первое из них кратно 5, а второе оканчивается на 3, заменить каждое из них их квадратом, в противном случае заменить каждое из них их квадратным корнем, округлив его до ближайшего целого. Вывести новые значения переменных.

Показать ответ
Ответ:
Артём0Болдырев
Артём0Болдырев
21.07.2021 02:01
Function IsPrime(n: integer): boolean;
  // Проверка, является ли число простым
var
  p: integer;
  found: boolean;
begin
  found := (n mod 2 = 0);
  p := 3;
  while (not found) and (sqr(p) <= n) do
  begin
    found := (n mod p = 0);
    p := p + 2
  end;
  IsPrime := (not found) or (p = 2)
end;

const
  n = 20;

var
  i, k: integer;
  a: array[1..n] of integer;

begin
  Write('Введите 20 целых чисел через пробел: ');
  for i := 1 to n do
  begin
    Read(a[i]);
  end;
  k := 0;
  for i := 1 to n do
    if IsPrime(a[i]) then k := k + 1;
  Writeln('Количество простых чисел- ', k)
end.

Тестовое решение:

Введите 20 целых чисел через пробел: 5 36 83 1673 339 73 34 14623 7 173 62 45 3463 326 28 934 345 24 4526 1143
Количество простых чисел- 6
0,0(0 оценок)
Ответ:
Умару11
Умару11
17.06.2022 10:34
Const
  k = 50;

var
  s, si, sf: string;
  powm, n10i: longint;
  i, j, m, ls, err, ni, nf: integer;
  a: double;

begin
  Write('Введите основание системы счисления (2..9): ');
  Readln(m);
  if not (m in [2..9]) then Writeln('Ну-ну...')
  else begin
    Write('Введите положительное число в этой системе счисления: ');
    Readln(s);
    ls := Length(Trim(s));
    i := pos('.', s);
    if i > 0 then begin
      ni := i - 1; si := Copy(s, 1, ni);
      nf := ls - i; sf := Copy(s, i + 1, nf)
    end
    else begin si := s; ni := ls; sf := ''; nf := 0 end;
    powm := 1; n10i := 0;
    for i := ni downto 1 do
    begin
      Val(si[i], j, err);
      n10i := n10i + j * powm;
      powm := powm * m
    end;
    powm := m; a := 0;
    for i := 1 to nf do
    begin
      Val(sf[i], j, err);
      a := a + j / powm;
      powm := powm * m
    end;
    a := a + n10i;
    Writeln(s, '(', m, ')=', a, '(10)')
  end;
end.

Тестовое решение:

Введите основание системы счисления (2..9): 8
Введите положительное число в этой системе счисления: 23532.5034
23532.5034(8)=10074.6318359375(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота