В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
okfuh
okfuh
24.01.2021 04:10 •  Информатика

1) написать программу, вычисления значений функции y=1/x+2 с шагом 0,1. значения аргумента беруться из [-1; 2) заполнить таблицу значений функции y=sqrt(1/2x-1)+2 c шагом 0,1. значения аргумента беруться из [0; 3,8]. предстоит продумать вопрос вывода найти значение x, при котором функция не определена..

Показать ответ
Ответ:
ваняшка
ваняшка
30.09.2020 14:09

 

 

program P1;
uses
crt;
var
x,y : real;
begin

clrscr;

x := -1;

writeln('');

while x <= 1 do
begin

y := 1/x+2;

x := x + 0.1;


writeln(y);

end;

writeln('');

writeln('');

x := 0;

writeln('');

while x <= 3.8 do
begin

if (x <> 0) and (1/(2*x)-1 >= 0) then
y := sqrt(1/(2*x)-1)+2 else
writeln('Pri X = ',x,' ne opredelena');

x := x + 0.1;


writeln(y);

end;

writeln('');

readln;
readln;

 


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота