В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nasyapest
nasyapest
16.09.2021 17:58 •  Информатика

1. напишите программу для создания трех массивов каждый их 8 элементов a b и c
2.заполните массив а с клавиатуры
3. заполните массив в квадратами номеров соответствующих элементов
4.заполните массив с случайными числами
5.выведите эти три массива на экран расположив их элементы в строку

Показать ответ
Ответ:
Frost2099
Frost2099
10.10.2020 22:23

var

a, b, c: array[1..8] of integer;

i: integer;

begin

for i := 1 to 8 do

read(a[i]);

for i := 1 to 8 do

b[i] := sqr(a[i]);

for i := 1 to 8 do

c[i] := random(10000);

for i := 1 to 8 do

write(a[i], ' ');

writeln();

for i := 1 to 8 do

write(b[i], ' ');

writeln();

for i := 1 to 8 do

write(c[i], ' ');

writeln();

end.

0,0(0 оценок)
Ответ:
Zvezdo4kaKatty
Zvezdo4kaKatty
10.10.2020 22:23

PascalABC.NET

begin

 var a := ReadArrInteger(8);

 var b := ArrGen(8, i -> i * i, 1);

 var c := ArrRandom(8, -99, 99);

 a.Println;

 b.Println;

 c.Println

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота