В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
NAstiu1
NAstiu1
10.11.2022 05:40 •  Информатика

1)напишите программу, которая строит "квадрат" из знаков '*' заданного размера. используйте процедуру. 2)напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. используйте процедуру. 3)напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами. 4)напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. используйте процедуру.

Показать ответ
Ответ:
zejbelanka
zejbelanka
16.07.2020 13:55
1)
#include <iostream>
using namespace std;
void draw_square(int n)
{
    for(int y = 0; y < n; y++)
    {
        for (int x = 0; x < n; x++)
            cout << "*";
        cout << endl;
   }
}
int main()
{
  int n;
  cin >> n;
  draw_square(n);
  return 0;
}

2)
#include <iostream>
using namespace std;
void drawNumbers(int a)
{
   while(a > 0)
   {
      cout << a%10 << endl;
      a /= 10;
   }
}
int main()
{
    int a;
    cin >> a;
    drawNumbers(a);
    return 0;
}

3)
#include <iostream>
using namespace std;
int main()
{
    //можно гораздо быстрей, но мне лень
    int a;
    cin >> a;
    for(int i = 1; i <= a; i++) if(a%i==0) cout << i << " ";
    return 0;
}

4)
#include <iostream>
using namespace std;
void procedure(int a)
{   
     int b = a;   
     int c = 1;   
     while(b > 0)  {c *= 10; b/=10;}   
     while(c > 1)   
     {       
          cout << (a%c)/(c/10) << endl;       
          c /= 10;   
     }
}
int main()

    int a; 
    cin >> a; 
    procedure(a); 
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота