1) напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. вход: программа получает на выход кол-во чисел, а затем сами числа. кол-во чисел не превышает 1000, а сами числа не превышают 30000. выход: программа должна вывести yes, если в последовательности есть хотя бы одно нечетное число не оканчивающиеся на 1 и no в противном случае. 2) напишите программу, которая в последовательности натуральных чисел находимо кол-во нечетных чисел кратных 3. вход: программа получает на выход кол-во чисел, а затем сами числа. кол-во чисел не превышает 1000, а сами числа не превышают 30000. выход: программа должна вывести одно число-кол-во нечётных чисел кратных 3.
var
x, n, i: integer;
flag: boolean;
begin
read(n);
flag := false;
for i := 1 to n do
begin
read(x);
if((x mod 10 <> 1) and (x mod 2 <> 0)) then
begin
flag := true;
break;
end;
end;
if(flag) then write('YES')
else write('NO')
end.
2)
var
x, n, i, count: integer;
begin
count := 0;
read(n);
for i := 1 to n do
begin
read(x);
if((x mod 3 = 0) and (x mod 2 <> 0)) then count := count + 1;
end;
write(count);
end.
var
a,k,i,c: integer;
begin
c:=0;
write('Введите количество чисел в последовательности: ');
readln(k);
for i := 1 to k do
begin
write('Введите число: ');
readln(a);
if (a mod 2 = 1) and (a mod 10 <> 1) then c:=c+1
end;
if c>0 then writeln('YES')
else writeln('NO')
end.
2.
var
a,k,i,c: integer;
begin
c:=0;
write('Введите количество чисел в последовательности: ');
readln(k);
for i := 1 to k do
begin
write('Введите число: ');
readln(a);
if (a mod 2 = 1) and (a mod 3 = 0) then c:=c+1
end;
writeln(c)
end.