В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
olchik75
olchik75
05.11.2021 16:47 •  Информатика

1.Напишите программу прерывание цикла с оператором continue? 2.Напишите код программы цикла while/ else/break?
3.Напишите программу вывода на экран таблицы умножения чисел от 1 до 9 разными

Показать ответ
Ответ:
vaniafatyanov
vaniafatyanov
05.12.2022 12:36
{-}
const
ch_1: array[1..19] of string = ('один', 'два', 'три', 'четыре', 'пять', 'шесть','семь', 'восемь', 'девять', 'десять', 'одиннадцать', 'двенадцать', 'тринадцать','четырнадцать', 'пятнадцать', 'шестнадцать', 'семнадцать', 'восемнадцать', 'девятнадцать');

ch_2: array [2..9] of string = ('двадцать', 'тридцать', 'сорок', 'пятьдесят', 'шестьдесят', 'семьдесят', 'восемьдесят', 'девяносто'); 

ch_3: array [1..9] of string = ('сто', 'двести', 'триста', 'четыреста', 'пятьсот', 'шестьсот', 'семьсот', 'восемьсот', 'девятьсот'); 

var
n : 0..1000;
begin
repeat
write ('Введите натуральное число, меньшее 1000: ');
readln (n);
until n in [1..999];

if n in [100..999] then write (ch_3[n div 100], ' ');
     if (n mod 100) in [20..99] then 
     begin 
         write (ch_2[(n mod 100)div 10], ' '); 
         if (n mod 10) <> 0 then write (ch_1[n mod 10]); 
     end 
     else 
     if (n mod 100) <>0 then write (ch_1[n mod 100]); 

end.
0,0(0 оценок)
Ответ:
фелекс54
фелекс54
05.12.2022 12:36
Program n1;
var
m, n: integer;
ms: array[1..9] of string;
md: array[1..9] of string;
m1: array[11..19] of string;
me: array[1..9] of string;
flag: boolean;
begin
flag := false;
ms[1] := 'сто'; ms[2] := 'двести'; ms[3] := 'триста'; ms[4] := 'Четыреста';
ms[5] := 'пятьсот'; ms[5] := 'пятьсот'; ms[6] := 'шестьсот'; ms[7] := 'семьсот';
ms[8] := 'восемьсот'; ms[9] := 'девятьсот';
md[1] := 'десять'; md[2] := 'двадцать'; md[3] := 'тридцать'; md[4] := 'сорок';
md[5] := 'пятьдесят'; md[6] := 'шестьдесят'; md[7] := 'семьдесят';
md[8] := 'восемьдесят'; md[9] := 'девяносто';
m1[11] := 'одиннадцать'; m1[12] := 'двенадцать'; m1[13] := 'тринадцать';
m1[14] := 'четырнадцать'; m1[15] := 'пятнадцать'; m1[16] := 'шестнадцать';
m1[17] := 'семнадцать'; m1[18] := 'восемнадцать'; m1[19] := 'девятнадцать';
me[1] := 'один'; me[2] := 'два'; me[3] := 'три'; me[4] := 'четыре'; me[5] := 'пять';
me[6] := 'шесть'; me[7] := 'семь'; me[8] := 'восемь'; me[9] := 'девять';

write('введите число: ');
readln(m);
if (m < 1) or (m > 1000) then writeln('число не входит в заданный интервал')
else
if m = 1000 then writeln('одна тысяча ')
else
begin
n := m div 100;
if n > 0 then
begin
write(ms[n]);
flag := true
end;
m := m mod 100;
if m = 0 then writeln(' ')
else
begin
if (m > 10) and (m < 20) then
begin
if flag then write(' ');
writeln(m1[m])
end
else
if m > 0 then
begin
n := m mod 10;
m := m div 10;
if m > 0 then
begin
if flag then write(' ') else flag := true;
Write(md[m])
end;
if n <> 0 then
begin
if flag then write(' ');
write(me[n]);
end
end
end
end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота