1. Напишите программу вычисления среднего арифметическо- го трёх целых случайных чисел, принадлежащих промежут- ку [0; 10). Предусмотрите вывод на экран случайных чисел, сгенерированных компьютером. НА ПИТОНЕ
Txt – первый формат для текстовых файлов, в котором не используется форматирование (размер шрифта, полужирный, отступ абзаца и пр,). Содержит только текст. .doc – формат, который использовался долгое время в текстовом редакторе Word компании Microsoft. Наиболее распространенный для текстовых редакторов. .docx – формат для текстового редактора Word компании Microsoft, который появился в пакете Microsoft office 07 (2007 год) и имеется в Office 10. Не все редакторы поддерживают данный формат, так как эта лицензионная разработка компании Microsoft. .odt – формат для текстового редактора Write пакета свободный офис (OpenOffice). .rtf – формат для текстового редактора, имеющий возможность использоваться в разных операционных системах, то есть, можно переносить с компьютера, имеющего одну операционную систему на другой компьютер с другой операционной системой. .pdf – формат для текстового файла, разработанных компанией Adobe. Имеется меньшие размеры и лучше передает рисунки по сравнению с другими форматами. Когда он был разработан, то редактор для создания подобных файлов нужно было купить у компании Adobe. В то же время для любого пользователя можно было скачать просмотровщик данного файла. Многие компании делали текстовую информацию именно в этом формате, поэтому он стал популярен. .chm – формат файла, который используется для хранения нескольких файлов формата html. Создан для замены формата справочной системы. Может иметь ссылки, по которым возможен переход на другую страницу.
Задача №1 //PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016) Var n, i: integer; Begin writeln ('Введите число'); readln(n); writeln('Делители числа:'); for i := 1 to n div 2 do if (n mod i) = 0 then begin write(i,' '); end; End.
Задача №2 (алгоритм не очень шустрый, но работает и понятный) //PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016) var a, b, x, y, nod: integer;
begin writeln('Введите a,b'); readln(a, b); x := a;y := b; while x <> y do if x > y then x := x - y else y := y - x; nod := x; writeln('NOD(', a, ',', b, ')=', nod); end.
.doc – формат, который использовался долгое время в текстовом редакторе Word компании Microsoft. Наиболее распространенный для текстовых редакторов.
.docx – формат для текстового редактора Word компании Microsoft, который появился в пакете Microsoft office 07 (2007 год) и имеется в Office 10. Не все редакторы поддерживают данный формат, так как эта лицензионная разработка компании Microsoft.
.odt – формат для текстового редактора Write пакета свободный офис (OpenOffice).
.rtf – формат для текстового редактора, имеющий возможность использоваться в разных операционных системах, то есть, можно переносить с компьютера, имеющего одну операционную систему на другой компьютер с другой операционной системой.
.pdf – формат для текстового файла, разработанных компанией Adobe. Имеется меньшие размеры и лучше передает рисунки по сравнению с другими форматами. Когда он был разработан, то редактор для создания подобных файлов нужно было купить у компании Adobe. В то же время для любого пользователя можно было скачать просмотровщик данного файла. Многие компании делали текстовую информацию именно в этом формате, поэтому он стал популярен.
.chm – формат файла, который используется для хранения нескольких файлов формата html. Создан для замены формата справочной системы. Может иметь ссылки, по которым возможен переход на другую страницу.
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer;
Begin
writeln ('Введите число');
readln(n);
writeln('Делители числа:');
for i := 1 to n div 2 do
if (n mod i) = 0 then begin
write(i,' ');
end;
End.
Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
a, b, x, y, nod: integer;
begin
writeln('Введите a,b');
readln(a, b);
x := a;y := b;
while x <> y do
if x > y
then x := x - y
else y := y - x;
nod := x;
writeln('NOD(', a, ',', b, ')=', nod);
end.