В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
negatiff95
negatiff95
13.04.2021 22:28 •  Информатика

1.напишите программу, вычисляющую значение функции: y =5 при x< 2 2 при x=2 10 при x> 2(программа паскаль) 2.дан условный оператор: if a< 7 then c: =10 else if a> 7 then c: =2 else c: =5 какое значение имеет переменная а, если в результате выполнения условного оператора переменной с присваивается значение 5? (программа паскаль)

Показать ответ
Ответ:
LisenokHan
LisenokHan
26.08.2020 09:28
Var
Y,X:real;
Begin
Write('X = ');ReadLn(X);
if X<2 then Y:=5
else if X=2 then Y:=2
     else Y:=10;
WriteLn('Y = ',Y);
End.

2)

c = 5, когда не выполняется оба условия, то есть:

If a<7 then c:=10        // a>=7
else if a>7 then c:=2    // a>7
else c:=5

Переменная a может иметь любое значение больше семи.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота