В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Боббоянн
Боббоянн
05.02.2023 20:07 •  Информатика

1.с клавиатуры вводят слово и симвал.составьте программу ,которая а)проверяет,есть ли в этом слове данный симвал. б)определяет позицию данного символа. в)подсчитывает количество входов данного символа. 2.с клавиатуры вводят
ряд и слово.составьте программу ,которая а)определяет позицию данного слова. сделайте что сможете !

Показать ответ
Ответ:
натали19852
натали19852
23.05.2020 18:16

 Вот первая программа. Вторую сейчас пишу.

program p_1;
var
a,b:string;
i,k:integer;
begin
k:=0;
write('Введите слово ');
readln(a);
write('Введите символ ');
readln(b);
for i:=1 to length(a) do
begin
if a[i]=b then k:=k+1;
if a[i]=b then writeln(i,' ');
end;
if k>=1 then
writeln('Да, встречается ',k,' раз, на позиции указанных сверху в столбик ')else writeln('Нет');
end.

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота