В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sasha030506
Sasha030506
24.04.2022 03:38 •  Информатика

1. составить программу, которая формирует массив из 15 случайных чисел от -20 до 20 и четные числа возводит в квадрат. на экран выводятся исходные данные и преобразованные значения через 4 пробела. 2. составить программу, которая формирует массив из 10 целых чисел, элементы массива вводятся вручную с клавиатуры. поменять местами первый и последний элементы массива и вывести на экран.

Показать ответ
Ответ:
ника2545
ника2545
07.10.2020 08:59
1.
Program arrays;
const n = 15;
Var a:array [1..n] of integer;
    i:integer;
begin
  for i:=1 to n do a[i]:= random(-20, 20);
  for i:=1 to n do
  begin
    if a[i] mod 2 = 0 then
      a[i]:=sqr(a[i]);
  end;
  for i:= 1 to n do write(a[i], ' ');
end.
2.
Program arrayss;
const n = 10;
Var a:array [1..n] of integer;
    i:integer;
begin
  for i:=1 to n do read(a[i]);
  swap(a[1], a[10]);
  for i:= 1 to n do write(a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота