В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
galikhina2006
galikhina2006
20.01.2021 12:54 •  Информатика

1. составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2. составить программу, которая вычисляет сколько лет можно выполнять план по отлову рыбы, если запасы рыбы составляют а тонн, ежегодный прирост рыбы 25%, ежегодный план отлова с тонн. pascalabc

Показать ответ
Ответ:
StacyZviozdohkina
StacyZviozdohkina
07.10.2020 21:52
1)
Program n1;
var sum,k,a: integer;
begin
sum:=0;
k:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
k:=k+1;
readln(a);
end;
write('сумма: ',sum,'; срзнач: ',sum/k);
end.
2)
Program n2;
var a,c,sum: real;
k: integer;
begin
k:=1;
readln(a,c);
sum:=a;
repeat
sum:=sum+a*0.25;
k:=k+1;
until sum>=c;
write(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота