В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
HFccv
HFccv
24.01.2022 04:25 •  Информатика

1)составьте программу, которая заполняет массив a случайными целыми числами в диапазоне от 1 до 20 и вывода на экран элементов массива с нечётными значениями. 2) соединить : d 1- двоичный код 2- кодирование 3- система счисления 4- основание 5- разряд а- процесс преобразования информации из одной форму представления в другую б- набор из нулей и едениц в- позиция цифры в числе г запичи чисел д- число цифр, которые используются в системе счисления для записи чисел

Показать ответ
Ответ:
agayevaaysu
agayevaaysu
10.07.2020 18:18
Const N = 10;
var a: array[1..N] of integer;
  i: integer;
begin
  randomize;
  writeln('исходный массив');
  for i := 1 to N do begin
    a[i] := Random(20) + 1;
    write(a[i]:3);
  end;
  writeln;
  writeln('нечетные значения');
  for i := 1 to N do
    if a[i] mod 2 = 1 then 
      write (a[i]:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота