В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Serpopi
Serpopi
13.01.2021 06:45 •  Информатика

1)составьте программу на языке pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком. 2)составьте программу на языке pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.

Показать ответ
Ответ:
afspafa
afspafa
09.08.2020 14:20
1)

var
mas: array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 10 do begin
if mas[i]<0 then
write(abs(mas[i]),' ')
else
write(-mas[i],' ');
end;
end.

2)

var
mas: array [1..10] of real;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 5 do
write(mas[i]*2,' ');
for i:=6 to 10 do
write(mas[i]/2,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота