В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Анютик200511
Анютик200511
06.10.2020 10:01 •  Информатика

1. Заполните массив кубами случайных целых чисел в интервале (1,5). Перемножьте все элементы списка с четными индексами (то есть A[0], A[2], A[4], ...). Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов.
Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

ответом на задачи является программа на языке python.

Показать ответ
Ответ:
урган1
урган1
01.02.2022 07:51

Программа:

Python:

№1)

A = list(input().split())

pr = 1

for i in range(len(A)):

   if i % 2 == 0:

       pr *= int(A[i])

print(f'{A}\n{pr}')

№2)

from random import randint

arr = [randint(-10, 10) for i in range(10)]  # массив из 10 чисел от -10 до 10

pr = 1

for i in arr:

   if i % 2 == 0 and i != 0:  pr *= i

print(f'{arr}\n{pr}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота