№12 составьте программу для нахождения таблицы значений при решении системы уравнений если z< 1 ү= ✓|3z + cosz^3| если z< 1 ү=4z-✓z/ sin^4(z-2) если z≥1 если z изменяется от -2 до 3 с шагом 1 по информатике, начинается решение вот так 10 rem
{Задачу можно решать несколькими Одним из возможных является перебор всех четырехзначных чисел и проверка для каждого из них выполнения условий. Попробуем сократить перебор, для этого преобразуем второе условие: 10а+b-(10c+d)=a+b+c+d; 9(a-c)=2(c+d); (a-c)/(c+d)=2/9 Проанализировав первое условие, получаем, что а=с+2, d=9-c, следовательно 0<=c<=7.}
program prim4; uses crt; var a,b,c,d: integer; begin clrscr; for c:=0 to 7 do begin a:=c+2; d;=9-c; for b:=0 to 9 do begin if (b<>c)and(b<>a)and(b<>d) then write(a,b,c,d); writeln end; end; readln; end.
{Таким образом, мы решили задачу, значительно сократив перебор.}
Линейка нужна для изменения расстояния (между точками) с незначительной погрешностью. Транспортир нужен для измерения градусной меры угла с незначительной погрешностью. Термометр нужен для измерения температуры. Барометр нужен для измерения атмосферного давления. Компас нужен для ориентирования по магнитным полюсам Земли. Телескоп нужен для того, чтобы увидеть отдалённые объекты. Микроскоп нужен для того, чтобы увидеть незримые невооружённым глазом тела. Абак нужен для упрощения счёта. Детектор Гейгера нужен для измерения радиационного фона. =)
10а+b-(10c+d)=a+b+c+d;
9(a-c)=2(c+d);
(a-c)/(c+d)=2/9
Проанализировав первое условие, получаем, что а=с+2, d=9-c, следовательно 0<=c<=7.}
program prim4;
uses crt;
var a,b,c,d: integer;
begin
clrscr;
for c:=0 to 7 do
begin
a:=c+2; d;=9-c;
for b:=0 to 9 do
begin
if (b<>c)and(b<>a)and(b<>d)
then
write(a,b,c,d);
writeln
end;
end;
readln;
end.
{Таким образом, мы решили задачу, значительно сократив перебор.}
Транспортир нужен для измерения градусной меры угла с незначительной погрешностью.
Термометр нужен для измерения температуры.
Барометр нужен для измерения атмосферного давления.
Компас нужен для ориентирования по магнитным полюсам Земли.
Телескоп нужен для того, чтобы увидеть отдалённые объекты.
Микроскоп нужен для того, чтобы увидеть незримые невооружённым глазом тела.
Абак нужен для упрощения счёта.
Детектор Гейгера нужен для измерения радиационного фона.
=)