2.Написать программу, с цикла выводить умножение на 7 в диапазоне от 0 до 11.3.Пользователь вводит число. Написать программу с цикла производить умножение(от 0 до 11) на это число.4.Дано натуральное число n (n<9999). Выяснить, верно ли, что это число содержит ровно три одинаковые цифры с учетом четырех цифр, как, например, 3363, 4844, 0300 и т. п.
ВЫПОЛНИТЬ С
#include <iostream>
using ll = long long;
using ld = long double;
using namespace std;
signed main() {
// problem 2 //
for(ll i = 0; i < 11; i++)
cout << i << " * 7 = " << i*7 << "\n";
// problem 2 //
// problem 3 //
ll x;
cout << "Введите число: ";
cin >> x;
for(ll i = 0; i < 11; i++)
cout << "\n" << i << " * " << x << " = " << i*x;
cout << "\n";
// problem 3 //
// problem 4 //
ll num;
cout << "Введите четырехзначное число: ";
cin >> num;
ll a[10];
for(ll i = 0; i < 10; i++)
a[i] = 0;
while(num > 0){
a[num % 10]++;
num /= 10;
}
bool ok = false;
for(auto i: a)
if(i == 3)
ok = true;
if(ok)
cout << "Данное число содержит ровно 3 одинаковые цифры";
else
cout << "Данное число не содержит ровно 3 одинаковые цифры";
// problem 4 //
}