В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ViKa09089009
ViKa09089009
25.09.2020 21:30 •  Информатика

2) Напишите программу, которая считывает три строки по очереди, а затем выводит все возможные комбинации из этих слов, разделяя комбинации запятой.

Показать ответ
Ответ:
DianaSmile111
DianaSmile111
07.01.2022 07:33
1. var a: array[1..10] of integer;
          i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] mod 2=0 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
2. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] > 9 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
3. var a: array[1..10] of integer;
    i: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
4. var a: array[1..10] of integer;
    i, r: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  i := 1;
  while i < 10 do
    if a[i+1] < a[i] then begin
      r := a[i+1];
      a[i+1] := a[i];
      a[i] := r;
      i := 1;
    end else i := i + 1;
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
5. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 10 = 5 then kol := kol + 1;
  writeln(kol);
End.
0,0(0 оценок)
Ответ:
Lukaeyrik05
Lukaeyrik05
27.12.2020 10:28

1.

1) s := (x1+x2)/2

2) dec(k) или k:=k-1

3) inc(i) или i:=i+1

4) sum := t*kt + r*kr + k*kk (t, r, k - цена одной тетради, ручки, карандаша;  kt, kr, kk - количество тетрадей, ручек и карандашей) 

 

2.

а) значения функции y=х(в квадрате)

var y,x: real

 

б) площади прямоугольника

var a,b,s: real

 

в)стоимости покупки,состоящей из нескольких тетрадей и такого же кол-ва обложек

var kv:integer; st,so,sum: real

 

г)стоимости покупки,состоящей из нескольких тетрадей,нескольких ручек и нескольких карандашей

var kvt,kvr,kvk:integer; st,sr,sk,sum: real

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота