2. составить программу для нахождения цифр четырехзначного числа. ниже представлен пример диалога. данные, вводимые пользователем, выделены жирным шрифтом. введите четырехзначное число 3281 число тысяч равно 3 число сотен равно 2 число десятков равно 8 число единиц равно 1
Program pr;
uses crt;
Var a, x1, x2, x3, x4:integer;
Begin
Writeln('введите 4-х значное число');
readln(a);
x1:=a div 1000;
x2:=(a mod 1000) div 100;
x3:=(a mod 100) div 10;
x4:=a mod 10;
Writeln(x1);
Writeln(x2);
Writeln(x3);
Writeln(x4);
readln;
end.