В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
VladeEZ
VladeEZ
20.07.2021 04:04 •  Информатика

20 ! составить программу на языке с++: 1. описать структуру с именем tovar, которая содержит следующие поля: - name - название товара; - cost_z - цена закупки товара; - cost_p - цена продукции. - quantity -количество единиц товара; - pributok - прибыль. 2. написать программу, которая использует данную структуру и выполняет следующие действия: - вводит из текстового файла sklad.dat список книг, согласно структуры, и выводит его на экран, используя элемент список; - вычисляет прибыль по каждому товару; - добавляет в начало списка n новых товаров; - удаляет товар, который приносит прибыль; - с вновь списка записать в двоичный файл sklad.sol все товары, которые имеют наибольшую прибыль. 3. написать программу, которая считывает из двоичного файла sklad_n.dat, данные обо всех товарах и записывает в файл tovar.dat товар, цена которого превышает среднюю цену товара .

Показать ответ
Ответ:
xnxnxnxnx
xnxnxnxnx
27.10.2021 07:04

esc-клавиша, предназначенная для возврата к предыдущему состоянию (меню, экрану) или выходу из приложения или программы (в случае, если выход таким в данной интерпретации предусмотрен приложением) .

Tab-нужно чтобы расставлять стопоры, которые выделяют красную строку и отступ

Caps Lock-предназначенная для фиксации смены регистра букв со строчных на прописные.

Enter- для подтверждение

Backspase- удаляет текст, или букву

Num Lock- для переключения и фиксации числового регистра, расположена в левом верхнем углу цифрового блока клавиатуры

Space- для пробела

Shift-предназначенная для ввода заглавных букв

F1 – кнопка вызова справки системы, если вы находитесь на рабочем столе. Она же вызывает в активной программе.

F2 – можно переименовать файл или папку, которая выделена. Это работает и на рабочем столе, и в проводнике.

F3 – кнопка активирует поиск в проводнике. Это также работает на рабочем столе.  

F4 – в проводнике открывает адресную строку. В сочетании с клавишей обновить активное окно. Особенно это удобно делать в браузере, когда надо обновить страницу открытого сайта. В Word открывает раздел «найти и заменить», с которой вы быстро перейдёте на нужную страницу.

F6 – в большой части она применяется в браузере. Нажав, вы сразу перемещаетесь в адресную строку.

F7 – при работе в одной из офисных приложений Microsoft, делает проверку правописания.

F8 – её основное предназначение – это при загрузке Windows открывает список режимов включения операционной системы.

F9 – происходит обновление Word. Если же вы в Outlook, то примете или же отправите почту.

F10 – в проводнике открывает панель инструментов. В сочетании с Shift работает как правая кнопка мышки.

F11 – в браузере переходит в полноэкранный режим и выходит из неё.

F12 – открывает окно «сохранить как …» в Word.

0,0(0 оценок)
Ответ:
alisha15sherban
alisha15sherban
21.02.2021 10:24

program season;

var

 number_month: integer;

begin

 write('Введите номер месяца: ');

 read(number_month);

 case number_month of

   1, 2, 12: writeln('Зима.');

   3..5: writeln('Весна.');

   6..8: writeln('Лето.');

   9..11: writeln('Осень.');

 else writeln('Неверный номер месяца.');

 end

end.

Объяснение:

program season;  // Название программы

var

 number_month: integer;  // Целочисленная переменная, отвечающая за вводимый номер месяца с клавиатуры

begin  // Начало программы

 write('Введите номер месяца: ');  // Вывод сообщения

 read(number_month);  // Ввод номера месяца с клавиатуры

 case number_month of  // Принимает значение переменной number_month

   1, 2, 12: writeln('Зима.');  // Если значение переменной number_month = 1, 2, 12, то выводим "Зима"

   3..5: writeln('Весна.');  // Если значение переменной number_month = 3, 4, 5, то выводим "Весна"

   6..8: writeln('Лето.');  // Если значение переменной number_month = 6, 7, 8, то выводим "Лето"

   9..11: writeln('Осень.');  // Если значение переменной number_month = 9, 10, 11, то выводим "Осень"

 else writeln('Неверный номер месяца.');  // Иначе выводим сообщение об ошибке

 end  // Конец функции

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота