25 ! ! нужно составить программу на языке с++! : реализовать программу «телефонный справочник» с использованием двусвязного списка требования к программе: ● максимальное количество записей в справочнике ограничено. ● каждый запись должна содержать следующую информацию: им 'я (до 10 символов включительно), фамилия (до 20 символов), номер телефона (до 12 цифр). все поля обязательно 'обязательными (не могут быть пустыми). ● ключевое поле - номер телефона (в справочнике может существовать только одна запись с указанным номером). ● структура хранения записей в справочнике - двозвьязний список. ● после запуска программа выводит на экран меню: 1. добавить запись 2. удалить запись 3. найти запись 4. показать все записи 5. сортировать записи 6. сохранить в файле 7. скачать с файла 8. выйти из программы и просит пользователя сделать выбор. ● после выбора пользователя программа при необходимости может пригласить дополнительную информацию (например, номер телефона для удаления записи). ● после выполнения операции по запросу пользователя программа сообщает о ее результат (успешное завершение или ошибка), просит пользователя нажать любую клавишу для продолжения. затем снова выводит на экран меню. ● для удаления записи необходимо указать номер телефона. ● для поиска записи необходимо указать фамилию или номер телефона. ● сортировка записей выполняется по фамилии и имени. ● имя 'я файла для хранения данных справочника - phone.dat программа должна контролировать ввода пользователем и хранить работо при введении сознательно неверных данных (например, слишком длинной строки как имени или неразрешенных символов в номере телефона).
*Черные чернила. Изобретением чернил мы также обязаны древнему Египту. Для их изготовления египтяне смешивали сажу, растительную смолу и пчелиный воск. Чтобы сделать чернила разных цветов, они заменяли сажу с другим органическим материалом. Например, они использовали охру вместо сажи, чтобы сделать чернила красными
* Плуг. Изобретение плуга не только коренным образом развило сельское хозяйство египетской общины, но модифицированная версия до сих пор используются фермерами отсталых стран, которые не могут себе позволить купить автоматические комбайны.
* Часы. Египтяне научили мир определять время суток, придумав часы. Они изобрели два типа часов: солнечные и водяные часы. Солнечные часы - это были обелиски на которых движущиеся тени в течение дня египтянам определять время дня.
const
n=100; // заменить на 10000
var
a:array[1..n] of byte;
i:byte;
j:integer;
begin
// инициализация, для
for j:=1 to n do a[j]:=Random(256);
// собственно программа
for i:=0 to 255 do
for j:=1 to n do
if a[j]=i then Write(i,' ');
end.
Тестовое решение:
5 8 9 11 11 14 14 17 18 19 21 22 24 24 29 30 33 36 40 45 46 47 55 55 56 58 61 62 64 66 68 73 74 75 85 88 91 94 96 96 96 98 102 103 108 109 111 111 116 119 122 123 129 129 130 135 137 139 143 144 149 149 155 155 160 169 170 173 177 178 181 182 190 193 196 198 199 199 200 206 206 207 209 222 224 225 226 229 230 235 237 240 243 246 249 250 251 252 254 255