В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
КейтKate
КейтKate
18.11.2020 10:21 •  Информатика

4. написать программу, которая после введенного с клавиатуры числа (в диапа-зоне от 1 до 99), обозначающего денежную единицу, дописывает слово "копейка" в правильной форме. например, 5 копеек, 41 копейка и т.д. в vbs

Показать ответ
Ответ:
Amarcy
Amarcy
27.11.2022 20:33
Могу в предложить в данном случае использовать goto и метки. Ну, если вы имеете какой то признак неправильных данных, например, это отрицательные значения (предположим, что это неправильные данные) То на этапе, когда вы вводите эти значения, вы должны поставить условный оператор. Т.е.
if a<0 tnen
begin
Writeln('Вы ввели неверные данные');
goto 1
else
goto 2;
Метку 1 вы ставите в начало алгоритма, т.е. туда, откуда вы хотите начать повторное выполнение программы, а метку 2 поставить в продолжение алгоритма, т.е. на тот случай, если данные были введены верно
0,0(0 оценок)
Ответ:
Mikich2
Mikich2
30.09.2020 13:55

Привет, код ниже, для справки по функциям советую посетить MSDN.
Если остаются вопросы так же есть хороший сайт как METANIT, там ты можешь найти простые примеры и простую документацию.
Если хочется проверить работаю кода, то есть прекрасный ресурс как Repl It.
Если есть вопросы, пиши в комментариях. За дополнительной информацией пиши в ЛС.

за отметку "Лучшее решение" и нажатую кнопочку и у меня в профиле.
Так же в моем профиле вы можете найти полезные ссылки на ресурсы описанные выше.



using System;

class MainClass {
  public static int (int[] array)
  {
    int result = 1;
   
    foreach (int element in array)
    {
      if (0 > element)
      {
        result *= element;
      }
    }
   
    return result;
  }

  static void Main()
  {
    Console.WriteLine("Please, enter length of array: ");
    int sizeOfArray = Convert.ToInt32(Console.ReadLine());
   
    int[] array = new int[sizeOfArray];
   
    for (int i = 0; i < sizeOfArray; ++i)
    {
      Console.WriteLine("Please, enter array entry: ");
      array[i] = Convert.ToInt32(Console.ReadLine());
    }
   
    int productOfNegativeNumbers = (array);
    Console.WriteLine("Product of negative numbers is: {0}", productOfNegativeNumbers);
  }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота