В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
elizka070408
elizka070408
03.09.2022 05:09 •  Информатика

4. напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a; b), или 0 в противном случае

Показать ответ
Ответ:
zubayr3
zubayr3
05.07.2020 22:42
1.
var a,b,r,s:integer;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите остатки r и s: ');
readln(r,s);
if (a mod b=r) or (a mod b=s) then writeln('Да, верно')
  else writeln('Нет, неверно')
end.

2.
var a,b,x:real;
begin
write('Введите числа a и b: ');
readln(a,b);
write('Введите x: ');
readln(x);
if (a<=x) and (x<=b) then writeln(1)
  else writeln(0)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота