В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sino4ka
Sino4ka
25.08.2020 16:10 •  Информатика

4. Составьте программу на языке Паскаль записанную на
алгоритмическом языке:
алг Деление дробей
цел a, b, c, d, m, n
нач
ввод a, b, c, d,
m:= a×d (Числитель)
n:=b×c (Знаменатель)
вывод m, n
кон

Показать ответ
Ответ:
vitalyrtss
vitalyrtss
15.10.2020 05:12

Var

a, b, c, d, m, n:integer;

Begin

Readln(a, b, c, d) ;

m:=a*d;

n:=b*c;

Write(m, ', ', n) ;

End.

0,0(0 оценок)
Ответ:
ник5045
ник5045
16.01.2024 19:39
Хорошо, вот программа на языке Паскаль для деления дробей:

```
program DivisionOfFractions;
var
a, b, c, d, m, n: integer;
begin
writeln('Введите числитель и знаменатель первой дроби:');
readln(a, b);

writeln('Введите числитель и знаменатель второй дроби:');
readln(c, d);

m := a * d; // Вычисление числителя
n := b * c; // Вычисление знаменателя

writeln('Результат деления:');
writeln('Числитель:', m);
writeln('Знаменатель:', n);
end.
```

Пояснение к программе:

1. В начале программы объявляем переменные `a`, `b`, `c`, `d`, `m` и `n` типа integer. Они будут использоваться для хранения введенных и расчитанных значений.

2. Затем, используя оператор `begin`, начинаем основную часть программы.

3. С помощью `writeln` выводим сообщение "Введите числитель и знаменатель первой дроби:". Затем с помощью `readln` считываем значения числителя и знаменателя первой дроби и сохраняем их в переменные `a` и `b`.

4. Повторяем те же действия для второй дроби. В первом `writeln` выводится сообщение "Введите числитель и знаменатель второй дроби:" и считываем значения числителя и знаменателя в переменные `c` и `d`.

5. После этого производим вычисления.

- `m` присваивается значение `a * d`, то есть произведение числителя первой дроби на числитель второй дроби. Это будет числитель результата деления.
- `n` присваивается значение `b * c`, то есть произведение знаменателя первой дроби на знаменатель второй дроби. Это будет знаменатель результата деления.

6. Затем, с помощью `writeln` выводим сообщение "Результат деления:", а затем выводим значения `m` и `n` (числитель и знаменатель) на новых строках.

7. В конце программы ставим точку. Это означает конец программы.

Таким образом, эта программа на языке Паскаль позволяет пользователю ввести две дроби в виде числителей и знаменателей, а затем вычислить и вывести результат их деления на экран.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота