В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sveta6729
sveta6729
09.06.2023 01:46 •  Информатика

6. написать программу тремя с циклами «до», «пока» и с параметром ). : ввести n чисел. найти сумму четных из них. проанализируйте решения. какое проще и почему?

Показать ответ
Ответ:
rambobamborap08ffj
rambobamborap08ffj
16.06.2020 11:59

uses crt;

var s,n,ch:integer;

begin

for i:=1 to n do

begin

if ch mod 2 = 0 then

s:=s+ch;

end;

end.

 

uses crt;

var s,n,ch,i:integer;

begin i:=1;

while i <=n do

begin

if ch mod 2 = 0 then

s:=s+ch; inc(i);

end;

end.

 

 

uses crt;
var s,n,ch,i:integer;
begin i:=1;
n:=5;
repeat
begin
readln(ch);
if ch mod 2 = 0 then
s:=s+ch; inc(i);
end;
until i>=n;

writeln(s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота