В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
wasdas390wasdas390
wasdas390wasdas390
12.12.2022 05:34 •  Информатика

А)составить программу, которая увеличивает в 10 раз все элементы массива. б) заменяет все отрицательные элементы их индексами. сделать нужно и а и б. через паскаль надо.

Показать ответ
Ответ:
Гомункулис
Гомункулис
04.10.2020 09:51
//PascalABC.NET 3.2 сборка 1318

//а

begin
  writeln('Введите размерность:');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  ar.Transform(x -> x*10);
  ar.Print;
end.

//б

begin
  writeln('Введите размерность');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  for var i:=0 to n-1 do            //индексация с 0
    if ar[i]<0 then ar[i]:=i;
  ar.Print;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота