Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nicecherry23
10.11.2021 15:32 •
Информатика
Паскаль. написать функцию, находящую максимальное из двух вещественных чисел и с её определить максимальное из 4-х вводимых с клавиатуры вещественных чисел.
Показать ответ
Ответ:
isaevaa24
01.10.2020 19:03
Готово
function max(a1, a2:integer):integer;
begin
if a1>a2 then max:=a1 else max:=a2;
end;
var
a, b, c, d: integer;
begin
readln(a, b, c, d);
write(max(max(a, b), max(c, d)));
end.
Если есть какие-то вопросы или ещё нужна в ЛС.
0,0
(0 оценок)
Популярные вопросы: Информатика
mrrr15
16.03.2020 17:21
Дан значок «Мой компьютер»: MycomputerПоменяй значок «Мой компьютер» на другой. Выбери возможные варианты изображения значка ...
evrolokki
21.07.2020 00:53
Могут ли индексы элементов матрицы принимать отрицательные и нулевые значения?...
Игорь2285
22.02.2023 19:33
Дано натуральное число: Из этих чисел удалить Цифру А (А вводится с клавиатуры) написать в С++...
Rozaroza1234
24.02.2023 21:19
3. Задана кодовая информация в виде ряд чисел 1) Декодируй эту информатию и запиши сет: 23 24 25 24 43 45 32 162 2) Закодируй слово ИНФОРМАЦИЯ ера удро од номер...
Liка25
22.06.2022 22:31
Напишите программу на питоне. Найти сумму большего и меньшего из трёх чисел...
veraserditih
20.05.2020 09:48
Прочитай текст.Какуие казахские музыкальные инструменты ты знаешь? 1...
sasaaaru
28.07.2020 21:16
Для преобразования фигуры в контур необходимо нажать: Shift+Ctrl+C (в операционной системе windows) или Shift+Command+C (в операционной системе Mac OS) Невозможно...
mun7890
28.07.2020 21:16
Какая комбинация клавиш используется для группировки объектов в векторном редакторе? Выберите один вариант ответа. Ctrl+G (в операционной системе windows) или Command+G...
ritaazarenko5
21.05.2020 14:46
Не выполняя построения графика, определите, возрастает или убывает данная функция: а) у = 1/3х; б) у = -x + 1; в) у = -10х; г) у = 0,1х - 4....
ДЭМКО
21.05.2020 14:46
Найдите наименьшее и наибольшее значения линейной функции: а) у = -3x на отрезке [-2; 1]; б) у = 2,5x - 2 на луче (-∞; 2]; в) у = 1,5x на луче [-2; +∞); г) у = -x...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function max(a1, a2:integer):integer;
begin
if a1>a2 then max:=a1 else max:=a2;
end;
var
a, b, c, d: integer;
begin
readln(a, b, c, d);
write(max(max(a, b), max(c, d)));
end.
Если есть какие-то вопросы или ещё нужна в ЛС.