Анализ Проанализируйте программу робота «Часовой». Обратите внимание на числовые параметры, используемые в блоках. Может ли робот выполнить все функции военного часового? Какую функцию он не сможет выполнить? Объясни почему НО БУДЕТ НАПИСАНО 10 .10 УМНОЖТЕ НА 2 БУДЕТ 20
где N - количество цветов, b - основание системы счисления, в которой производится кодировка.
В данном случае N=16, b=2.
Значит: 16=2^i
2^4=2^i
i=4(бит)
V=i*m*n=4*640*480=1228800(бит)=1228800/8=153600(байт)=153600/1024=150 (кБайт)
ответ: 150кБайт.
2) Тоже самое:
256=2^i;
2^8=2^i
i=8(бит)
V=i*m*n=8*20*20=3200(бит)=3200/8=400(байт)
ответ: 400 байт.
3)- Что имеется в виду в выражении "высокого качества"? Какие параметры частоты дискретизации и уровней звука? Сколько каналов записи?
4) V=k*i, где V - объем сообщения, i - информационный вес, k - кол-во символов в сообщении.
i=V/k=3кБайт/3072=3*1024*8/3072=8 (бит)
По формуле Хартли: N=b^i, где N - мощность алфавита, b - основание системы счисления, в которой кодируется алфавит, i - информационный вес. N=2^8=256
ответ: N=256.
5) V=S*p*i
S=9*13=117(см2)
p=1400
i=5бит
V=117*1400*5=819000(бит)=819000/8=102375(байт)=102375/2^20=0,097(Мбайт)≈0,1(Мбайт)
ответ: ≈0,1(Мбайт)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли. Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a и написать программу:
var a,b:integer;
begin
repeat
writeln('Введите количество непроданных билетов (a,b)');
readln(a,b);
until (a<=120) and (b<=40)and (a>=0) and (b>=0);
writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.