C++ builder написать программу информацию о докторах клиники написать программу информацию о футбольных клубах написать программу информацию о цвете (типо кнопка с наименованием "красный" показывал красный цвет при нажатии)
#include <iostream> #include <cstdlib> #include <vector> using namespace std;
int main() { vector<int> v; cout <<"Укажите размер массива: "; int s; cin >>s; srand(time(0)); for(int i=0; i!=s; ++i) v.push_back(rand()%100); int find; cout <<"Введите число для поиска: "; cin >>find; bool founded = false; for(auto it=v.begin(); it!=v.end(); ++it) if(*it==find) founded=true; if(founded) cout <<"Это число есть в массиве!" <<endl; else cout <<"Такого числа нет в мвссиве!" <<endl;
1. Если имеется в виду язык Pascal, то получим следующее: var: a; //PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016) begin readln(a); b:=a+a; writeln (b); end.
Program50.pas(5) : Неизвестное имя 'b'
2. Попробуем такой вариант на Python
a =int(input()) b = a+a print(b)
При вводе а получим на выходе 10
Получается, что в Pacal требуется объявлять переменные в секции переменных, или в любом месте программы можно объявить переменную с служебного слова var для PascalABC.net. Первый код можно переписать так, и он будет работать:
var: a; //PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016) begin readln(a); var b:=a+a; writeln (b); end.
#include <cstdlib>
#include <vector>
using namespace std;
int main()
{
vector<int> v;
cout <<"Укажите размер массива: ";
int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";
cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;
else cout <<"Такого числа нет в мвссиве!" <<endl;
return 0;
}
var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
readln(a);
b:=a+a;
writeln (b);
end.
Program50.pas(5) : Неизвестное имя 'b'
2. Попробуем такой вариант на Python
a =int(input())
b = a+a
print(b)
При вводе а получим на выходе 10
Получается, что в Pacal требуется объявлять переменные в секции переменных, или в любом месте программы можно объявить переменную с служебного слова var для PascalABC.net. Первый код можно переписать так, и он будет работать:
var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
readln(a);
var b:=a+a;
writeln (b);
end.
Рузультат при введенном значении 5 равен 10