В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Любчик908
Любчик908
11.12.2021 11:47 •  Информатика

(c#) Напишите программу, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа сообщает, сколько чисел было введено. using System;

namespace z1
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введите начальное число");
int n = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите число");
int a = Convert.ToInt32(Console.ReadLine());
int k = 1;
while (true)
{
if (n < a)
{
k += 1;
n = a;
return;
}
Console.WriteLine("Введите число");
int b = Convert.ToInt32(Console.ReadLine());
}
Console.WriteLine($"кол-во чисел - {k}");
}
}
}
Почему код не работает?(50b)

Показать ответ
Ответ:
lollo2003
lollo2003
05.07.2020 02:45

using System;

namespace restless

{

   class Program

   {

       static void Main()

       {

           int x = Convert.ToInt32(Console.ReadLine());

           int _counter = x.ToString().Length;

           bool IsEven = (x & 1) == 0 ? true : false;

           if (_counter == 1 && IsEven)

               Console.WriteLine("Четное однозначное число");

           else if (_counter == 1 && !IsEven)

               Console.WriteLine("Нечётное однозначное число");

           

           else if (_counter == 2 && IsEven)

               Console.WriteLine("Чётное двузначное число");

           else if (_counter == 2 && !IsEven)

               Console.WriteLine("Нечётное двузначное число");

           

           else if (_counter == 3 && IsEven)

               Console.WriteLine("Чётное трехзначное число");

           else if (_counter == 3 && !IsEven)

               Console.WriteLine("Нечётное трехзначное число");

       }

   }

}

0,0(0 оценок)
Ответ:
тупой172
тупой172
25.05.2023 16:27

Выделите одну или несколько ячеек, которые необходимо использовать в качестве основы для заполнения других ячеек.

Например, если требуется задать последовательность 1, 2, 3, 4, 5..., введите в первые две ячейки значения 1 и 2. Если необходима последовательность 2, 4, 6, 8..., введите 2 и 4.

Если необходима последовательность 2, 2, 2, 2..., введите значение 2 только в первую ячейку.

Перетащите маркер заполнения Маркер заполнения.

При необходимости щелкните значок Параметры автозаполнения Изображение кнопки и выберите подходящий вариант.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота