В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kristinэ
kristinэ
14.03.2021 10:05 •  Информатика

C++ ПОЛНАЯ ПРОГРАММА НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅10^9
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
14 21
Вывод
42

Показать ответ
Ответ:
drazzgaming
drazzgaming
19.07.2022 15:02

Объяснение:

#include <iostream>

using namespace std;

long nod (int a, int b)  {

   return b == 0 ? a : nod (b, a % b);

}

int main() {

   int t1, t2;

   cin >> t1 >> t2;

   cout <<  t1 * (t2 / nod (t1, t2));

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота