В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
PomogitePLZZZzzzz
PomogitePLZZZzzzz
22.02.2021 06:31 •  Информатика

Чему будет равно значение переменной p при a=4 и n=3 после выполнения программы program test var a, p: integer; i, n: real; begin write (введите два натуральных числа) readln (a,n); p: =1 for i: =1 to n do p: =p*a; writeln (p=,p) end.

Показать ответ
Ответ:
валентина268
валентина268
02.10.2020 11:00
На самом деле, программа и правда из рук вон криво написана, начиная от простой понятности и лаконичности и заканчивая работо

Рабочий вариант, если я правильно понял ваш код:
Program Yolo;
Uses Crt;
Var a: integer; i, n: byte; p: longint;
Begin
  ClrScr;
 Writeln('Введите число и его степень.');
 Readln(a, n);
 p:=1;
 For i:=1 to N do
  p:=p*a;
 Writeln('Получившиеся число: ', p);
 Readln;
End.

4 в степени 3 будет равен 64.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота