В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
hamkochan
hamkochan
08.11.2021 14:14 •  Информатика

Через станцию проходят 10 поездов. в массиве хранится время отправления этих поездов. составить программу распечатывающую все поезда, отправляющиеся с 10до 11 часов. составить ​

Показать ответ
Ответ:
tuni2
tuni2
22.02.2022 19:13
program cube; var a : real; begin writeln('Программа вычисляет объем куба и площадь '+ 'его боковой поверхности по длине ребра'); {I - ввод + ЗОД} repeat write('Введите длину ребра куба '); readln(a); if a<=0 then writeln('Ошибка! Длина ребра не может быть нулевой или отрицательной. '+ 'Повторите ввод.'); until a>0; {II, III - расчет и вывод} writeln('Длина ребра куба = ',a:8:3,' м'); writeln('Объем этого куба = ', (a*a*a):8:3,' м^3'); writeln('А площадь его боковой поверхности = ', (6*a*a):8:3,' м^2'); writeln('Нажмите [Enter] для завершения программы'); readln; end.
0,0(0 оценок)
Ответ:
rahat9
rahat9
30.10.2020 03:08
Слишком много вопросов, поэтому ответы будут даны без подробных разъяснений.
1. В году 12 месяцев, выбор 1 из 12.
I=log_212\approx 3.585
2. В месяце максимум 31 день, минимум - 28 дней. Выбор от 1 из 31 до 1 из 28. Соответственно, количество информации будет в диапазоне:
[log_228;log_231]\approx[4.807;4.4.954]
3. В сутках 24 часа, выбор 1 из 24.
log_224\approx 4.585
4.В неделе 7 дней, выбор 1 из 7.
log_27\approx 2.807
5. I=log_2N \to N=2^I; \ N=2^8=256
6. Если каждый раз делить интервал пополам и задавать вопрос "Находится ли число..", указывая любую из половинок, то число не превысит семи.
log_2120\approx 6.907 - N=7
7. Как и в предыдущем случае, надо угадать одно число из 64-31+1=34
log_27\approx 2.807 \to N=3
Надо задать три вопроса.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота