В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tony23
tony23
15.05.2023 04:03 •  Информатика

Задание 5. Составьте программу подсчета количества часов, минут и секунд в данном числе суток. Число суток введите с клавиатуры.​

Показать ответ
Ответ:
ijezz
ijezz
21.01.2021 20:30

Неправильно считает секунды, в чём ошибка?

var

s,m,h,days: integer;

begin

writeln('Введите кол-во дней');

read(days);

s:=86400;

m:=s div 60;

h:=m div 60;

for var i:=1 to days do

s:=s*days;

m:=m*days;

h:=h*days;

writeln(s,' — секунд в ',days,' днях');

writeln(m,' — минут в ',days,' днях');

writeln(h,' — часов в ',days,' днях');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота