Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
555Sofiya5555
09.05.2021 17:13 •
Информатика
Дан целочисленный массив на 10 элементов.найти количество и сумму элементов кратных k
Показать ответ
Ответ:
katyakot2299
23.09.2020 14:47
Var a:array[1..10] of integer;
i,k,s,r:integer;
begin
for i:=1 to 10 do readln(A[i]);
writeln('Введите число k');
readln(k);
s:=0;
r:=0;
for i:=1 to 10 do
if (A[i]modk=0) then begin
r:=r+1;
s:=A[i]+s;
end;
writeln(s,r);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Солі
13.06.2021 22:01
Дано трехзначное число n. определить будет ли сумма его цифр четным числом...
anastasiabojko5
24.02.2022 13:02
Какое количество информации (в байтах) при игре крестики-нолики на поле размером 2х2 клетки получится по окончании игры? (с решением)...
Аскарбинка25
10.04.2023 20:05
АлгЯзык: 37 - Операторы div и mod 1. Чему будет равна переменная «c» после выполнения этой программы: a := 22 b := 4 b := div(a,b) + b c := mod(a,b) + a ответ: введите...
Eerow
18.03.2021 21:59
Пирожок в столовой стоит a рублей и b копеек. определите, сколько рублей и копеек нужно заплатить за n пирожков. программа получает на вход три числа: a, b, n и должна...
morni228
21.04.2023 14:13
З якого знака починається запис формули в середовищі табличного процесора...
diasjabarrrrrrrr
21.09.2021 06:04
В ячейке B4 находится формула МИН:(А3 B3) Как изменится формула и куда переместится при вставки к пустого столбца перед столбцом 1...
drsoffia
12.05.2020 01:50
Нароод предложение является неполным изза...
kvaisberg
12.05.2020 01:50
Снежный барс обитает на территории обозначенной цифрой...
mipad0302
12.05.2020 01:50
Написать о деревне используя слова next to, opposite, between, on the left/right....
saraikinacaterina
12.05.2020 01:50
Запишите какую нибудь десятичную дробь расположенную между числами 25,7 и 25,8...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,k,s,r:integer;
begin
for i:=1 to 10 do readln(A[i]);
writeln('Введите число k');
readln(k);
s:=0;
r:=0;
for i:=1 to 10 do
if (A[i]modk=0) then begin
r:=r+1;
s:=A[i]+s;
end;
writeln(s,r);
end.