В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alikhankoshpanov
alikhankoshpanov
13.12.2022 00:10 •  Информатика

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — выписать его нечётные элементы на те же места во второй массив b того же размера, а остальные элементы массива b заполнить нулями. Формат входных данных
В первой строке входных данных вводится натуральное число n (n≤500) — количество элементов массива.
Во второй строке лежат n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.

входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
1 3 3 7

0 0 0 3 0

Показать ответ
Ответ:
Даня0987853339
Даня0987853339
23.04.2021 13:04

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

int N;

cin >> N;

vector<int> a(N, 0);

for (int i = 0; i < N; i++) {

 int b;

 cin >> b;

 if (b % 2 != 0)

  a[i] = b;

}

for (int i = 0; i < N; i++)

 cout << a[i]<<" ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота