В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
shuoksana2014
shuoksana2014
10.04.2020 02:37 •  Информатика

♥♥♥♥ дан массив из 20 произвольных элементов, каждый из которых не больше 100. найдите максимальный элемент кратный 6.

Показать ответ
Ответ:
anjelanartokova
anjelanartokova
26.08.2020 10:56
Const k=6;
var a:array [1..20] of integer;
i,max:integer;
Begin
max:=-1;
for i:=1 to 20 do begin
a[i]:=random(100); (или for i:=1 to 20 do writeln(a[i]); - здесь ручной ввод)
if a[i] mod k = 0 then begin
if a[i]>max then max:=a[i]; end;
end;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота